summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-27 23:39:46 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-07-27 23:39:56 +1000
commit9712ef8d426375f7bc1975ed4076663176c48735 (patch)
treeab57f9175b7f700092bc6e8ab75d148cfe36779a
parent12c8f210ee6ba184fd77ebd0566c8cc4855e9636 (diff)
downloadguix-patches-9712ef8d426375f7bc1975ed4076663176c48735.tar
guix-patches-9712ef8d426375f7bc1975ed4076663176c48735.tar.gz
gnu: krona-tools: Update to 2.7.
* gnu/packages/web.scm (krona-tools): Update to 2.7. [arguments]: Delete 'build' phase. Install new scripts.
-rw-r--r--gnu/packages/web.scm32
1 files changed, 11 insertions, 21 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 33c1e88a5d..c17bcc8f47 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -283,7 +283,7 @@ parse JSON formatted strings back into the C representation of JSON objects.")
(define-public krona-tools
(package
(name "krona-tools")
- (version "2.6.1")
+ (version "2.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -291,24 +291,14 @@ parse JSON formatted strings back into the C representation of JSON objects.")
version "/KronaTools-" version ".tar"))
(sha256
(base32
- "1fj5mf6wbwz7v74n2safbw7fpw32fik19vf0wdbc2srn82i8fiwz"))))
+ "0wvgllcqscsfb4xc09y3fqhx8i38pmr4w55vjs5y79wx56n710iq"))))
(build-system perl-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
;; There is no configure or build steps.
(delete 'configure)
- (replace 'build
- ;; Remove 'use lib' statements from scripts as PERL5LIB is set
- ;; correctly during installation.
- (lambda _
- (for-each
- (lambda (executable)
- (display executable)(display "\n")
- (substitute* executable
- (("use lib \\(`ktGetLibPath`\\);") "")))
- (find-files "scripts/" ".*"))
- #t))
+ (delete 'build)
;; Install script "install.pl" expects the build directory to remain
;; after installation, creating symlinks etc., so re-implement it
;; here.
@@ -325,7 +315,9 @@ parse JSON formatted strings back into the C representation of JSON objects.")
(copy-file executable (string-append bin "/kt" script))))
'("ClassifyBLAST"
"GetContigMagnitudes"
- "GetTaxIDFromGI"
+ "GetLCA"
+ "GetTaxIDFromAcc"
+ "GetTaxInfo"
"ImportBLAST"
"ImportDiskUsage"
"ImportEC"
@@ -341,13 +333,11 @@ parse JSON formatted strings back into the C representation of JSON objects.")
"ImportTaxonomy"
"ImportText"
"ImportXML"))
- (copy-recursively "data" (string-append perl "/../data"))
- (copy-recursively "img" (string-append perl "/../img"))
- (copy-recursively "taxonomy" (string-append perl "/../taxonomy"))
- (install-file "src/krona-2.0.js" (string-append perl "/../src"))
- (substitute* "lib/KronaTools.pm"
- (("`ktGetLibPath`")
- (string-append "\"" perl "\"")))
+ (for-each
+ (lambda (directory)
+ (copy-recursively directory
+ (string-append perl "/../" directory)))
+ (list "data" "img" "taxonomy" "src"))
(install-file "lib/KronaTools.pm" perl))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)