summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 09:47:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 10:06:35 +0200
commit62a4ed258c27d19bf168095981ebf7bb1d381051 (patch)
tree7af7282e988b7590a6aa3976e11bb3e83d6db5aa
parent8d0ac5697c0b6cb37bbf5f7464298da525535e36 (diff)
downloadguix-patches-62a4ed258c27d19bf168095981ebf7bb1d381051.tar
guix-patches-62a4ed258c27d19bf168095981ebf7bb1d381051.tar.gz
gnu: Add python-connection-pool.
* gnu/packages/python-xyz.scm (python-connection-pool): New variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eaaa58d3fb..cdb6300117 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14398,6 +14398,23 @@ be set via config files and/or environment variables.")
(home-page "https://github.com/bw2/ConfigArgParse")
(license license:expat)))
+(define-public python-connection-pool
+ (package
+ (name "python-connection-pool")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "connection_pool" version))
+ (sha256
+ (base32 "1p6hfkcl4n3hhhcgjbaxn21i7b1yipag6j7dnilir4k5xxx9whmz"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/zhouyl/ConnectionPool")
+ (synopsis "Thread-safe connection pool")
+ (description "This package provides a library implementing a thread-safe
+connection pool.")
+ (license license:expat)))
+
(define-public python-argparse-manpage
(package
(name "python-argparse-manpage")