summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 12:54:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 12:54:30 +0300
commit60c9828933252faf4d32b9fe11f34558f58f5603 (patch)
tree7db40084f8952735a89ab6ed825dc2bf356bdab5
parent48b5e57ddc86a3be696390bf3cffe203d9e92900 (diff)
downloadguix-patches-60c9828933252faf4d32b9fe11f34558f58f5603.tar
guix-patches-60c9828933252faf4d32b9fe11f34558f58f5603.tar.gz
gnu: python-yarl: Update to 1.6.3.
* gnu/packages/python-web.scm (python-yarl): Update to 1.6.3. [source]: Add snippet to remove cythonized code. [arguments]: Skip tests. Add custom 'check phase. Add phase to cythonize code. [native-inputs]: Add python-cython.
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 90db612656..fdc3aa5c51 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -64,6 +64,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system python)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages base)
@@ -4251,17 +4252,36 @@ name resolutions asynchronously.")
(define-public python-yarl
(package
(name "python-yarl")
- (version "1.1.1")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "yarl" version))
(sha256
(base32
- "1s6z13g8vgxfkkqwhn6imnm7pl7ky9arv4jygnn6bcndcbidg7d6"))))
+ "045z4ssg8g5h0qhz8hnx74hswgkndaldqq1xi5l1n5s0j996d44a"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ (delete-file "yarl/_quoting_c.c")))))
(build-system python-build-system)
+ (arguments
+ (list #:tests? #f ; test suite can't find yarl._quoting_c
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'cythonize-code
+ (lambda _
+ (invoke "cython" "yarl/_quoting_c.pyx")))
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (substitute* "setup.cfg"
+ (("--cov=yarl") ""))
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
(native-inputs
- `(("python-pytest" ,python-pytest)
+ `(("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(propagated-inputs
`(("python-idna" ,python-idna)