summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-18 17:55:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-19 22:20:14 +0200
commit3110c74b98eab04183a0fc4573a97f9997ea818c (patch)
treec23c812c2e17c2966b745a2b8d57bafaccc0b0fe
parent9e1ede95df446f17df3c2164766545daeea472d3 (diff)
downloadguix-patches-3110c74b98eab04183a0fc4573a97f9997ea818c.tar
guix-patches-3110c74b98eab04183a0fc4573a97f9997ea818c.tar.gz
Revert "gnu: Remove Mr. Rescue."
This reverts commit 33f61dc1b5e14f8a2e3dfb3fb48102bda0fd6b13. The game can be patched to run on Löve 11 (done in a separate commit for clarity).
-rw-r--r--gnu/packages/games.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 06ac1b80bb..e5d5765ff3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3252,6 +3252,53 @@ application that locks the keyboard and mouse and instead displays bright
colors, pictures, and sounds.")
(license license:gpl3+)))
+(define-public mrrescue
+ (package
+ (name "mrrescue")
+ (version "1.02e")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/SimonLarsen/mrrescue/releases/"
+ "download/" version "/" name version ".love"))
+ (file-name (string-append name "-" version ".love"))
+ (sha256
+ (base32
+ "0jwzbwkgp1l5ia6c7s760gmdirbsncp6nfqp7vqdqsfb63la9gl2"))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (bindir (string-append out "/bin"))
+ (prog (string-append bindir "/mrrescue"))
+ (source (assoc-ref %build-inputs "source"))
+ (bash (string-append (assoc-ref %build-inputs "bash")
+ "/bin/bash"))
+ (love (string-append (assoc-ref %build-inputs "love")
+ "/bin/love")))
+ (mkdir-p bindir)
+ (with-output-to-file prog
+ (lambda ()
+ (format #t "#!~a~%" bash)
+ (format #t "exec -a mrrescue \"~a\" \"~a\"~%" love source)))
+ (chmod prog #o755)
+ #t))))
+ (inputs
+ `(("bash" ,bash)
+ ("love" ,love)))
+ (home-page "http://tangramgames.dk/games/mrrescue")
+ (synopsis "Arcade-style fire fighting game")
+ (description
+ "Mr. Rescue is an arcade styled 2d action game centered around evacuating
+civilians from burning buildings. The game features fast paced fire
+extinguishing action, intense boss battles, a catchy soundtrack and lots of
+throwing people around in pseudo-randomly generated buildings.")
+ (license (list license:zlib ; for source code
+ license:cc-by-sa3.0)))) ; for graphics and music assets
+
(define-public hyperrogue
(package
(name "hyperrogue")