summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2022-05-08 01:45:36 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-20 20:13:35 +0200
commit1594d6c93a5c7d927bd7505c689e267560df73db (patch)
tree3e0ab5d2189fdef7a4739fad72af99858b15dcc4
parentbbb7957881af7cf359d30f041247a0d786aa3888 (diff)
downloadguix-patches-1594d6c93a5c7d927bd7505c689e267560df73db.tar
guix-patches-1594d6c93a5c7d927bd7505c689e267560df73db.tar.gz
gnu: Add python-kivymd.
* gnu/packages/python-xyz.scm (python-kivymd): New symbol. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4794195c8f..b8fd857fd6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18670,6 +18670,35 @@ for Kivy, the multitouch application platform.")
multitouch applications.")
(license license:expat)))
+(define-public python-kivymd
+ (package
+ (name "python-kivymd")
+ (version "0.104.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "kivymd" version))
+ (sha256
+ (base32 "04lwy6j0agrdwa4a6dl6qs97nx9ysmscmm8psvdzjpyj8aa1zg4p"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ;tests require network
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'sanity-check 'set-home
+ (lambda _
+ ;; 'kivy/__init__.py' wants to create $HOME/.kivy.
+ (setenv "HOME" (getcwd)))))))
+ (native-inputs (list python-docutils))
+ (propagated-inputs
+ (list python-kivy python-pillow python-pygments python-kivy-garden))
+ (home-page "https://github.com/kivymd/KivyMD")
+ (synopsis "Material Design compliant widgets for use with Kivy")
+ (description
+ "This package provides Kivy widgets that approximate Google's Material
+Design spec without sacrificing ease of use or application performance.")
+ (license license:expat)))
+
(define-public python2-kivy
(package-with-python2 python-kivy))