summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 22:57:13 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:44 +0200
commitd146de283b8bb466136ca212a97138650f35fd77 (patch)
tree8936d618372b53c11dc215d6f1f96bbea883ce31
parentbb4546defdb79e0cd28d42b5d9f67f3d6a38373b (diff)
downloadguix-patches-d146de283b8bb466136ca212a97138650f35fd77.tar
guix-patches-d146de283b8bb466136ca212a97138650f35fd77.tar.gz
gnu: Add erlang-bbmustache.
* gnu/packages/erlang.scm (erlang-bbmustache): New variable.
-rw-r--r--gnu/packages/erlang.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 7abfc76cc9..e9c026be5a 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -206,6 +206,38 @@ built-in support for concurrency, distribution and fault tolerance.")
files.")
(license license:asl2.0)))
+(define-public erlang-bbmustache
+ (package
+ (name "erlang-bbmustache")
+ (version "1.12.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "bbmustache" version))
+ (sha256
+ (base32 "0fvvaxdpziygxl30j59g98qkh2n47xlb7w5dfpsm2bfcsnj372v8"))))
+ (build-system rebar-build-system)
+ (inputs
+ (list erlang-getopt rebar3-git-vsn
+ erlang-edown)) ; for building the docs
+ (arguments
+ `(#:tests? #f ;; requires mustache specification file
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'build-more
+ (lambda _
+ (invoke "rebar3" "as" "dev" "escriptize")))
+ (add-after 'install 'install-escript
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (install-file "_build/dev/bin/bbmustache"
+ (string-append out "/bin"))))))))
+ (home-page "https://github.com/soranoba/bbmustache/")
+ (synopsis "Binary pattern match Based Mustache template engine for Erlang")
+ (description "This Erlang library provides a Binary pattern match Based
+Mustache template engine")
+ (license license:expat)))
+
(define-public erlang-certifi
(package
(name "erlang-certifi")