summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 23:18:32 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:44 +0200
commitbb4546defdb79e0cd28d42b5d9f67f3d6a38373b (patch)
tree909dd80e6296457f1ee4a080548034b17ccf512d
parenta6a1e4b9f40d3a9d0cce27c4d466e7e6e9697fc4 (diff)
downloadguix-patches-bb4546defdb79e0cd28d42b5d9f67f3d6a38373b.tar
guix-patches-bb4546defdb79e0cd28d42b5d9f67f3d6a38373b.tar.gz
gnu: Add erlang-cth-readable.
* gnu/packages/erlang.scm (erlang-cth-readable): New variable.
-rw-r--r--gnu/packages/erlang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 8ee5b98c82..7abfc76cc9 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -247,6 +247,27 @@ Mozilla's canonical set.")
printing extending the io:format syntax to add colours.")
(license license:expat)))
+(define-public erlang-cth-readable
+ (package
+ (name "erlang-cth-readable")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "cth_readable" version))
+ (sha256
+ (base32 "104xgybb6iciy6i28pyyrarqzliddi8kjyq43ajaav7y5si42rb8"))))
+ (build-system rebar-build-system)
+ (propagated-inputs
+ (list erlang-cf))
+ (arguments
+ `(#:tests? #f)) ;; no test-suite in hex-pm package
+ (home-page "https://github.com/ferd/cth_readable")
+ (synopsis "Common Test hooks for more readable logs for Erlang")
+ (description "This package provides an OTP library to be used for CT log
+outputs you want to be readable around all that noise they contain.")
+ (license license:bsd-3)))
+
(define-public erlang-erlware-commons
(package
(name "erlang-erlware-commons")