summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 22:05:11 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:44 +0200
commita6b7caa1908822fe276e7f39e9d1495a67afcca8 (patch)
tree7a55c042769a21d4b38312c68bd30d06a4fefa3f
parentd146de283b8bb466136ca212a97138650f35fd77 (diff)
downloadguix-patches-a6b7caa1908822fe276e7f39e9d1495a67afcca8.tar
guix-patches-a6b7caa1908822fe276e7f39e9d1495a67afcca8.tar.gz
gnu: Add erlang-getopt.
* gnu/packages/erlang.scm (erlang-getopt): New variable.
-rw-r--r--gnu/packages/erlang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index e9c026be5a..f6e9a27ac2 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -326,3 +326,20 @@ outputs you want to be readable around all that noise they contain.")
(description "Erlware Commons is an Erlware project focused on all aspects
of reusable Erlang components.")
(license license:expat)))
+
+(define-public erlang-getopt
+ (package
+ (name "erlang-getopt")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "getopt" version))
+ (sha256
+ (base32 "09pasi7ki1rivw9sl7xndj5qgjbdqvcscxk83yk85yr28gm9l0m0"))))
+ (build-system rebar-build-system)
+ (home-page "https://github.com/jcomellas/getopt")
+ (synopsis "Command-line options parser for Erlang")
+ (description "This package provides an Erlang module to parse command line
+arguments using the GNU getopt syntax.")
+ (license license:bsd-3)))