summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-30 19:38:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-30 19:43:27 +0200
commit93a86ed72f4beb8a3ee7def66e9ed3535a0e8cb4 (patch)
tree21b97e17de2ff80d84177f0e57e4bbbaac3c0991
parent2e8025154d184f570b3bb00f85f119a6f90cbacb (diff)
downloadguix-patches-93a86ed72f4beb8a3ee7def66e9ed3535a0e8cb4.tar
guix-patches-93a86ed72f4beb8a3ee7def66e9ed3535a0e8cb4.tar.gz
gnu: zstd: Follow GNU conventions for make variables.
* gnu/packages/compression.scm (zstd)[arguments]: Use lowercase ones where possible.
-rw-r--r--gnu/packages/compression.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index c41830e206..86b6e431f0 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1399,9 +1399,9 @@ or junctions, and always follows hard links.")
#t))))
#:make-flags
(list "CC=gcc"
- (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "LIBDIR=" (assoc-ref %outputs "lib") "/lib")
- (string-append "INCLUDEDIR=" (assoc-ref %outputs "lib") "/include")
+ (string-append "prefix=" (assoc-ref %outputs "out"))
+ (string-append "libdir=" (assoc-ref %outputs "lib") "/lib")
+ (string-append "includedir=" (assoc-ref %outputs "lib") "/include")
;; Skip auto-detection of, and creating a dependency on, the build
;; environment's ‘xz’ for what amounts to a dubious feature anyway.
"HAVE_LZMA=0"