summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 23:22:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:45 +0200
commit6cec25f23207c1d99edc5b40814521221f8ae5d8 (patch)
treeda99400b5105fa6d5c7cfdd6af2cb3e2f2ce73ee
parenta6b7caa1908822fe276e7f39e9d1495a67afcca8 (diff)
downloadguix-patches-6cec25f23207c1d99edc5b40814521221f8ae5d8.tar
guix-patches-6cec25f23207c1d99edc5b40814521221f8ae5d8.tar.gz
gnu: Add erlang-eunit-formatters.
* gnu/packages/erlang.scm (erlang-eunit-formatters): New variable.
-rw-r--r--gnu/packages/erlang.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index f6e9a27ac2..e1f45a835b 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -327,6 +327,22 @@ outputs you want to be readable around all that noise they contain.")
of reusable Erlang components.")
(license license:expat)))
+(define-public erlang-eunit-formatters
+ (package
+ (name "erlang-eunit-formatters")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "eunit_formatters" version))
+ (sha256
+ (base32 "1jb3hzb216r29x2h4pcjwfmx1k81431rgh5v0mp4x5146hhvmj6n"))))
+ (build-system rebar-build-system)
+ (home-page "https://github.com/seancribbs/eunit_formatters")
+ (synopsis "Better output for eunit suites")
+ (description "This package provides a better output for Erlang eunits.")
+ (license license:asl2.0)))
+
(define-public erlang-getopt
(package
(name "erlang-getopt")