summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 23:18:41 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:48 +0200
commit4af9fa11308f294ad1fa254140dea2c0fb2c9495 (patch)
tree4af256936948f435aeccb0e596ddaf8644fb41c8
parent539695e9d5348cd759ba406e914bfe227c04d18f (diff)
downloadguix-patches-4af9fa11308f294ad1fa254140dea2c0fb2c9495.tar
guix-patches-4af9fa11308f294ad1fa254140dea2c0fb2c9495.tar.gz
gnu: Add erlang-relx.
* gnu/packages/erlang.scm (erlang-relx): New variable.
-rw-r--r--gnu/packages/erlang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 628d632dae..9318b0b953 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -427,6 +427,28 @@ compile-time constant.")
(description "This package provides an Erlang providers library.")
(license license:asl2.0)))
+(define-public erlang-relx
+ (package
+ (name "erlang-relx")
+ (version "4.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "relx" version))
+ (sha256
+ (base32 "02gmfx1vxg9m3mq4njsqhs4972l4nb8m5p1pdcf64g09ccf17y1g"))))
+ (build-system rebar-build-system)
+ (propagated-inputs
+ (list erlang-bbmustache))
+ (home-page "https://erlware.github.io/relx/")
+ (synopsis "Release assembler for Erlang/OTP Releases")
+ (description "Relx assembles releases for an Erlang/OTP release. Given a
+release specification and a list of directories in which to search for OTP
+applications it will generate a release output. That output depends heavily on
+what plugins available and what options are defined, but usually it is simply
+a well configured release directory.")
+ (license license:asl2.0)))
+
(define-public erlang-ssl-verify-fun
(package
(name "erlang-ssl-verify-fun")