summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-30 19:43:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-30 19:43:28 +0200
commit386457b7bda963be9f0119a785b71bc64e0c105e (patch)
tree880447a5d40c683f093d7dff233f73565b9b5435
parent93a86ed72f4beb8a3ee7def66e9ed3535a0e8cb4 (diff)
downloadguix-patches-386457b7bda963be9f0119a785b71bc64e0c105e.tar
guix-patches-386457b7bda963be9f0119a785b71bc64e0c105e.tar.gz
gnu: zstd: Update to 1.4.5.
* gnu/packages/compression.scm (zstd): Update to 1.4.5. [arguments]: Add new work-arounds for new Makefile problems.
-rw-r--r--gnu/packages/compression.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 86b6e431f0..8e7578d94d 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1360,14 +1360,14 @@ or junctions, and always follows hard links.")
(define-public zstd
(package
(name "zstd")
- (version "1.4.4")
+ (version "1.4.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/facebook/zstd/releases/download/"
"v" version "/zstd-" version ".tar.gz"))
(sha256
- (base32 "05ckxap00qvc0j51d3ci38150cxsw82w7s9zgd5fgzspnzmp1vsr"))))
+ (base32 "17nf0r20360i80689bg5ipxbk2413b2dn3z7wj8byqpiddy1rscq"))))
(build-system gnu-build-system)
(outputs '("out" ;1.2MiB executables and documentation
"lib" ;1.2MiB shared library and headers
@@ -1375,6 +1375,13 @@ or junctions, and always follows hard links.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-bogus-check
+ (lambda _
+ ;; lib/Makefile falsely claims that no .pc file can be created.
+ (substitute* "lib/Makefile"
+ (("error configured .*dir ")
+ "true "))
+ #t))
(delete 'configure) ;no configure script
(add-after 'install 'adjust-library-locations
(lambda* (#:key outputs #:allow-other-keys)
@@ -1402,6 +1409,9 @@ or junctions, and always follows hard links.")
(string-append "prefix=" (assoc-ref %outputs "out"))
(string-append "libdir=" (assoc-ref %outputs "lib") "/lib")
(string-append "includedir=" (assoc-ref %outputs "lib") "/include")
+ ;; Auto-detection is over-engineered and buggy.
+ "PCLIBDIR=lib"
+ "PCINCDIR=include"
;; Skip auto-detection of, and creating a dependency on, the build
;; environment's ‘xz’ for what amounts to a dubious feature anyway.
"HAVE_LZMA=0"