summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-09 15:28:19 +0000
committerLeo Famulari <leo@famulari.name>2021-10-16 17:32:25 -0400
commit747b98b32fbee2595026543f962375e792e2c7e7 (patch)
treef14ddd2a116e770e4178279ed8f1a91bc0bd2d7e
parent38582fb53cbf233284db1bfc63b907f0b86b3f4d (diff)
downloadguix-patches-747b98b32fbee2595026543f962375e792e2c7e7.tar
guix-patches-747b98b32fbee2595026543f962375e792e2c7e7.tar.gz
gnu: Add mp3guessenc.
* gnu/packages/audio.scm (mp3guessenc): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/audio.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a8764f99f4..faf106fc68 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4060,6 +4060,33 @@ machine-readable ASCII format.")
(home-page "https://github.com/svend/cuetools")
(license license:gpl2+)))
+(define-public mp3guessenc
+ (package
+ (name "mp3guessenc")
+ (version "0.27.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/mp3guessenc/mp3guessenc-"
+ (version-major+minor version) "/mp3guessenc-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1fa3sbwwn4p2v1749lzy040bfy1xfd574mf2frwgg9ikgk3vlb3c"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure phase
+ (home-page "https://mp3guessenc.sourceforge.io")
+ (synopsis "Analyze MPEG layer I/II/III files")
+ (description "mp3guessenc is a command line utility that tries to detect the
+encoder used for an MPEG Layer III (MP3) file, as well as scan any MPEG audio
+file (any layer) and print a lot of useful information.")
+ (license license:lgpl2.1+)))
+
(define-public shntool
(package
(name "shntool")