summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-10-13 00:53:06 -0400
committerArun Isaac <arunisaac@systemreboot.net>2021-10-16 16:53:10 +0530
commit34b0aa16e77bdbb5b847267eb0f825a590e3d101 (patch)
treec1dc56350e519130cb038324d80f6eb356622b71
parent62ca859aa4304c2399fd677e879c5b713b681784 (diff)
downloadguix-patches-34b0aa16e77bdbb5b847267eb0f825a590e3d101.tar
guix-patches-34b0aa16e77bdbb5b847267eb0f825a590e3d101.tar.gz
gnu: Add python-json2html.
* gnu/packages/python-xyz.scm (python-json2html): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6fd6749309..d7df77c577 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27308,6 +27308,35 @@ location. This small Python module determines the appropriate
platform-specific directories, e.g. the ``user data dir''.")
(license license:expat)))
+(define-public python-json2html
+ (package
+ (name "python-json2html")
+ (version "1.3.0")
+ (source
+ ;; There are no tests in the PyPI tarball.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/softvar/json2html")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ncypljnl5y8lsxy6ibcqy412kx3mzxl4ajg67568hvq98kv1sb3"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "test/run_tests.py")))))))
+ (home-page "https://github.com/softvar/json2html")
+ (synopsis "Convert JSON to HTML table")
+ (description "@code{python-json2html} is a python module to convert JSON
+into a human readable HTML table representation.")
+ (license license:expat)))
+
(define-public python-face
(package
(name "python-face")