summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-12 08:36:52 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 16:35:04 -0400
commite4fdcdee4cebcb757cb7dbf71618bce8492b7025 (patch)
tree0e2c7cb1103fdc548a26e8511dc65e8a21b103cc
parent0f9355c06cf684143e56d9c86f6d2b10bd15c325 (diff)
downloadguix-patches-e4fdcdee4cebcb757cb7dbf71618bce8492b7025.tar
guix-patches-e4fdcdee4cebcb757cb7dbf71618bce8492b7025.tar.gz
gnu: gtk+: Enable cloud-providers support.
* gnu/packages/gtk.scm (gtk+) [arguments]<#:configure-flags> [--enable-cloudproviders]: New flag. [propagated-inputs]: Add libcloudproviders. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fcc20884fe..266a8a8220 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -955,6 +955,7 @@ application suites.")
gdk-pixbuf+svg
gdk-pixbuf))
("glib" ,glib)
+ ("libcloudproviders" ,libcloudproviders)
("libepoxy" ,libepoxy)
("libx11" ,libx11)
("libxcomposite" ,libxcomposite)
@@ -1006,6 +1007,7 @@ application suites.")
#:configure-flags (list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html")
+ "--enable-cloudproviders"
;; The header file <gdk/gdkwayland.h> is required
;; by gnome-control-center
"--enable-wayland-backend"