summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-05 13:28:42 -0400
committerLeo Famulari <leo@famulari.name>2016-11-05 13:31:44 -0400
commit2d125a9b21306919e6123f76c0970988b14dadcf (patch)
tree7a9123dc3067e17a73cfb9cf32613afd9961d2ef
parent268b3802e9bb5336b087039d75eb0db7280f156f (diff)
downloadguix-patches-2d125a9b21306919e6123f76c0970988b14dadcf.tar
guix-patches-2d125a9b21306919e6123f76c0970988b14dadcf.tar.gz
gnu: weex: Update to 2.8.2 [fixes CVE-2005-3150].
* gnu/packages/ftp.scm (weex): Update to 2.8.2. [source]: Use new URL. Remove obsolete 'weex-vacopy.patch'. [arguments]: Remove custom 'configure' phase and add 'bootstrap' phase. [native-inputs]: Add autoconf, automake, and gnu-gettext. * gnu/packages/patches/weex-vacopy.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ftp.scm27
-rw-r--r--gnu/packages/patches/weex-vacopy.patch13
3 files changed, 12 insertions, 29 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 49b672111f..1ac336196d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -892,7 +892,6 @@ dist_patch_DATA = \
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
%D%/packages/patches/vtk-mesa-10.patch \
%D%/packages/patches/weechat-python.patch \
- %D%/packages/patches/weex-vacopy.patch \
%D%/packages/patches/wicd-bitrate-none-fix.patch \
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
%D%/packages/patches/wicd-urwid-1.3.patch \
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index a11265532a..eb622dd17c 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -25,6 +25,8 @@
#:use-module (guix download)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages readline)
#:use-module (gnu packages pkg-config)
@@ -126,31 +128,26 @@ FTP browser, as well as non-interactive commands such as 'ncftpput' and
(define-public weex
(package
(name "weex")
- (version "2.6.1.5")
+ (version "2.8.2")
(source
(origin
(method url-fetch)
(uri
- (string-append "mirror://sourceforge/weex/weex/" version
- "/weex-" version ".tar.gz"))
+ (string-append "mirror://sourceforge/weex/weex/"
+ "/weex_" version ".tar.gz"))
(sha256
(base32
- "0f5cj5p852wkm24mzy2sxgxyahv2p9rk4wlq21j310pi7wlhgwyl"))
- (patches (search-patches "weex-vacopy.patch"))))
+ "1ir761hjncr1bamaqcw9j7x57xi3s9jax3223bxwbq30a0vsw1pd"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("gettext" ,gnu-gettext)))
(arguments
`(#:phases
(modify-phases %standard-phases
- (replace 'configure
- ;; configure does not work followed by both "SHELL=..." and
- ;; "CONFIG_SHELL=..."; set environment variables instead
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bash (which "bash")))
- (setenv "SHELL" bash)
- (setenv "CONFIG_SHELL" bash)
- (zero? (system* bash "./configure"
- (string-append "--prefix=" out)))))))))
+ (add-before 'configure 'bootstrap
+ (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://weex.sourceforge.net/")
(synopsis "Non-interactive client for FTP synchronization")
(description
diff --git a/gnu/packages/patches/weex-vacopy.patch b/gnu/packages/patches/weex-vacopy.patch
deleted file mode 100644
index f593e86c08..0000000000
--- a/gnu/packages/patches/weex-vacopy.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Taken from the Debian 2.8.0 package.
-
---- weex-2.6.1.5/src/strlib.c 2003-08-18 11:52:38.000000000 +0200
-+++ weex-2.8.0/src/strlib.c 2007-12-04 14:22:02.000000000 +0100
-@@ -42,6 +42,8 @@
- # define G_VA_COPY(ap1, ap2) (*(ap1) = *(ap2))
- # elif defined (G_VA_COPY_AS_ARRAY)
- # define G_VA_COPY(ap1, ap2) g_memmove ((ap1), (ap2), sizeof (va_list))
-+# elif defined (__x86_64__)
-+# define G_VA_COPY(ap1, ap2) memmove ((ap1), (ap2), sizeof (va_list))
- # else /* va_list is a pointer */
- # define G_VA_COPY(ap1, ap2) ((ap1) = (ap2))
- # endif /* va_list is a pointer */