summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:27:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:57 +0100
commitbe0777ba865550e3bc80d6ef962e230233bae45f (patch)
treee377ae8ecc4ecf9f8ae49fb3c1654c01ca80dedb
parent4d1f19e02c99ca13de95fa57afa8e1e2a0702384 (diff)
downloadguix-patches-be0777ba865550e3bc80d6ef962e230233bae45f.tar
guix-patches-be0777ba865550e3bc80d6ef962e230233bae45f.tar.gz
gnu: Add r-penalized.
* gnu/packages/cran.scm (r-penalized): New variable.
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d087ffd26e..0c789dd69f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11260,3 +11260,31 @@ nested and non-nested models. The package also includes functionality to
obtain confidence intervals associated with AIC and BIC.")
;; Either version of the GPL.
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-penalized
+ (package
+ (name "r-penalized")
+ (version "0.9-51")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "penalized" version))
+ (sha256
+ (base32
+ "1zcrwa93mc27qj3g4ayc2k895r6g8q0g6qb2azmvj7wqk750va7a"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-survival" ,r-survival)))
+ (home-page "https://cran.r-project.org/web/packages/penalized/")
+ (synopsis "Penalized estimation in GLMs and in the Cox model")
+ (description
+ "This package provides tools for fitting possibly high dimensional
+penalized regression models. The penalty structure can be any combination of
+an L1 penalty (lasso and fused lasso), an L2 penalty (ridge) and a positivity
+constraint on the regression coefficients. The supported regression models
+are linear, logistic and Poisson regression and the Cox Proportional Hazards
+model. Cross-validation routines allow optimization of the tuning
+parameters.")
+ (license license:gpl2+)))