summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-02 13:49:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-02 13:49:57 +0200
commit4571b218b52c2f0386fda6c9b24d011e368c13f7 (patch)
tree26ba987f3cd078cbabb21656b2d69b095eb8f078
parent4642a50d526106c556c64862544f00532c6f0e79 (diff)
downloadguix-patches-4571b218b52c2f0386fda6c9b24d011e368c13f7.tar
guix-patches-4571b218b52c2f0386fda6c9b24d011e368c13f7.tar.gz
gnu: Remove python-xlrd-1.
* gnu/packages/python-xyz.scm (python-xlrd-1): Remove variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9e5ec4c54f..074cbeb970 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11739,32 +11739,6 @@ Unicode-aware. It is not intended as an end-user tool.")
(define-public python2-xlrd
(package-with-python2 python-xlrd))
-;; We need this for python-anndata
-(define-public python-xlrd-1
- (package
- (inherit python-xlrd)
- (name "python-xlrd")
- (version "1.2.0")
- (source (origin
- ;; The tests are not included in the PyPI archive.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/python-excel/xlrd")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0sm5p0ii5ayh52ak1jpw0n1kgsv72vdwwp8c3z13l8yf4irsb587"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Some tests depend on writing a temporary file to the user's home
- ;; directory.
- (add-after 'unpack 'fix-tests
- (lambda _
- (setenv "HOME" "/tmp"))))))))
-
;;; Note: this package is unmaintained since 2018 (archived on GitHub).
(define-public python-xlwt
(package