summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:24:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:57 +0100
commit01fe44cbdca1f59e993ff6fceeaa410df0fed27d (patch)
tree9bd9cd77e215695a9d5edd3a22b8df68b0a6ef5f
parent4fd994432f032446fbf3654ddd55c738e145e0ba (diff)
downloadguix-patches-01fe44cbdca1f59e993ff6fceeaa410df0fed27d.tar
guix-patches-01fe44cbdca1f59e993ff6fceeaa410df0fed27d.tar.gz
gnu: Add r-moments.
* gnu/packages/cran.scm (r-moments): New variable.
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 921a33fb26..2b5c2b021e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11146,3 +11146,23 @@ problems by a modification of the Levenberg-Marquardt algorithm, with support
for lower and upper parameter bounds. The implementation can be used via
@rode{nls}-like calls using the @code{nlsLM} function.")
(license license:gpl3)))
+
+(define-public r-moments
+ (package
+ (name "r-moments")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "moments" version))
+ (sha256
+ (base32
+ "0f9y58w1hxcz4bqivirx25ywlmc80gbi6dfx5cnhkpdg1pk82fra"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/moments")
+ (synopsis "Moments, cumulants, skewness, kurtosis and related tests")
+ (description
+ "This package provides functions to calculate: moments, Pearson's
+kurtosis, Geary's kurtosis and skewness; it also includes tests related to
+them (Anscombe-Glynn, D'Agostino, Bonett-Seier).")
+ (license license:gpl2+)))