summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:00 +0200
commit88b098d9ba523b41fac813ae6ee296579ceab659 (patch)
tree01618b7e3617f2ca2f6cd794ac275ae9ab969a19
parent67ff6767925d35c9d3a3c83cd21083ca8f930f02 (diff)
downloadguix-patches-88b098d9ba523b41fac813ae6ee296579ceab659.tar
guix-patches-88b098d9ba523b41fac813ae6ee296579ceab659.tar.gz
gnu: python-parted: Rename to python-pyparted.
* gnu/packages/disk.scm (python-pyparted): New variable renamed from… (python-parted): …this, to better follow the package naming guidelines. Redefine it using DEPRECATED-PACKAGE.
-rw-r--r--gnu/packages/disk.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 5524792188..47b15e588f 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -715,9 +715,9 @@ the card and then checks if can read it. It will assure you haven't been sold
a card with a smaller capacity than stated.")
(license license:gpl3+)))
-(define-public python-parted
+(define-public python-pyparted
(package
- (name "python-parted")
+ (name "python-pyparted")
(version "3.12.0")
(source
(origin
@@ -740,6 +740,9 @@ a card with a smaller capacity than stated.")
(description "This package provides @code{parted} bindings for Python.")
(license license:gpl2+)))
+(define-public python-parted
+ (deprecated-package "python-parted" python-pyparted))
+
(define-public duperemove
(package
(name "duperemove")