summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-07 22:20:02 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-14 14:23:21 -0400
commit3aaf52a129ccf1d42aefd31322d21f697ce026b4 (patch)
tree61bfed0179bcdacce0b98d1252d970c3831df2b7
parent330d2778a93a2f9618a3dec0846eaa04b240e4db (diff)
downloadguix-patches-3aaf52a129ccf1d42aefd31322d21f697ce026b4.tar
guix-patches-3aaf52a129ccf1d42aefd31322d21f697ce026b4.tar.gz
gnu: Add dbus-verbose.
* gnu/packages/glib.scm (dbus-verbose): New variable.
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 732b1aea8a..98267fcee5 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -193,6 +193,21 @@ shared NFS home directories.")
(("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-local.conf")
"/var/run/jami/session-local.conf")))))))))))
+;;; The reason this is not enabled in the regular dbus package is because it
+;;; impacts the performance of D-Bus (including its library) as a whole, even
+;;; when the DBUS_VERBOSE environment variable is not set.
+(define-public dbus-verbose
+ (package/inherit dbus
+ (name "dbus-verbose")
+ (arguments (substitute-keyword-arguments (package-arguments dbus)
+ ((#:configure-flags flags '())
+ `(cons "--enable-verbose-mode" ,flags))))
+ (synopsis "D-Bus with verbose mode enabled for debugging")
+ (description "This variant D-Bus package is built with verbose mode, which
+eases debugging of D-Bus services by printing various debug information when
+the @code{DBUS_VERBOSE} environment variable is set to @samp{1}. For more
+information, refer to the @samp{dbus-daemon(1)} man page.")))
+
(define glib
(package
(name "glib")