summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-15 15:52:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-15 15:52:24 +0200
commit0310517e6cf1de12ac39ec5ff92251146eb5da67 (patch)
treefd12aa277dc6217294eff70ed0bfdba651793384
parentd0951c288b97db42c470506ec62f4e14a76774b1 (diff)
downloadguix-patches-0310517e6cf1de12ac39ec5ff92251146eb5da67.tar
guix-patches-0310517e6cf1de12ac39ec5ff92251146eb5da67.tar.gz
gnu: mesa: Remove input labels.
* gnu/packages/gl.scm (mesa)[inputs, native-inputs]: Remove labels. (mesa-opencl)[inputs-, native-inputs]: Likewise, and use 'modify-inputs'.
-rw-r--r--gnu/packages/gl.scm64
1 files changed, 31 insertions, 33 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1d39f1839d..ad0c1a20e3 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -287,36 +287,34 @@ also known as DXTn or DXTC) for Mesa.")
libxxf86vm
xorgproto))
(inputs
- `(("expat" ,expat)
- ("libelf" ,elfutils) ;required for r600 when using llvm
- ("libva" ,(force libva-without-mesa))
- ("libxml2" ,libxml2)
- ("libxrandr" ,libxrandr)
- ("libxvmc" ,libxvmc)
- ,@(match (%current-system)
- ((or "x86_64-linux" "i686-linux" "powerpc64le-linux" "aarch64-linux"
- "powerpc-linux" "riscv64-linux")
- ;; Note: update the 'clang' input of mesa-opencl when bumping this.
- `(("llvm" ,llvm-11)))
- (_
- `()))
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)))
+ (append (list expat
+ elfutils ;libelf required for r600 when using llvm
+ (force libva-without-mesa)
+ libxml2
+ libxrandr
+ libxvmc
+ wayland
+ wayland-protocols)
+ (if (member (%current-system)
+ '("x86_64-linux" "i686-linux" "powerpc64le-linux"
+ "aarch64-linux" "powerpc-linux" "riscv64-linux"))
+ ;; Note: update the 'clang' input of mesa-opencl when bumping this.
+ (list llvm-11)
+ '())))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("gettext" ,gettext-minimal)
- ,@(match (%current-system)
- ((or "x86_64-linux" "i686-linux" "powerpc64le-linux" "aarch64-linux"
- "powerpc-linux" "riscv64-linux")
- `(("glslang" ,glslang)))
- (_
- `()))
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("python-libxml2", python-libxml2) ;for OpenGL ES 1.1 and 2.0 support
- ("python-mako" ,python-mako)
- ("which" ,(@ (gnu packages base) which))))
+ (append (list bison
+ flex
+ gettext-minimal
+ pkg-config
+ python-wrapper
+ python-libxml2 ;for OpenGL ES 1.1 and 2.0 support
+ python-mako
+ (@ (gnu packages base) which))
+ (if (member (%current-system)
+ '("x86_64-linux" "i686-linux" "powerpc64le-linux"
+ "aarch64-linux" "powerpc-linux" "riscv64-linux"))
+ (list glslang)
+ '())))
(outputs '("out" "bin"))
(arguments
`(#:configure-flags
@@ -519,11 +517,11 @@ from software emulation to complete hardware acceleration for modern GPUs.")
((#:configure-flags flags)
`(cons "-Dgallium-opencl=standalone" ,flags))))
(inputs
- `(("libclc" ,libclc)
- ,@(package-inputs mesa)))
+ (modify-inputs (package-inputs mesa)
+ (prepend libclc)))
(native-inputs
- `(("clang" ,clang-11)
- ,@(package-native-inputs mesa)))))
+ (modify-inputs (package-native-inputs mesa)
+ (prepend clang-11)))))
(define-public mesa-opencl-icd
(package/inherit mesa-opencl