summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@devup.no>2020-05-27 15:07:52 +0200
committerMarius Bakke <marius@gnu.org>2020-05-27 21:49:57 +0200
commit9c566d1b23f574298d1ff0fc1d2a904a441ec7b3 (patch)
tree6fada455ee44bd80ecef2039a07581619e06c347
parentfae1c86605046b3fbc93384170438382248faab3 (diff)
downloadguix-patches-9c566d1b23f574298d1ff0fc1d2a904a441ec7b3.tar
guix-patches-9c566d1b23f574298d1ff0fc1d2a904a441ec7b3.tar.gz
gnu: Add ruby-sys-filesystem.
* gnu/packages/ruby.scm (ruby-sys-filesystem): New public variable.
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2ab6dc2394..e32f93bec0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9320,6 +9320,35 @@ the Thin library.")
(home-page "https://github.com/sj26/skinny")
(license license:expat)))
+(define-public ruby-sys-filesystem
+ (package
+ (name "ruby-sys-filesystem")
+ (version "1.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sys-filesystem" version))
+ (sha256
+ (base32
+ "0mizqnsiagagmracadr16s5na2ks2j3ih1w0f3gp4ssrda6szl01"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ (lambda _
+ ;; Some tests attempt to stat $HOME. Let them.
+ (setenv "HOME" "/tmp")
+ #t)))))
+ (propagated-inputs
+ `(("ruby-ffi" ,ruby-ffi)))
+ (native-inputs
+ `(("ruby-mkmf-lite" ,ruby-mkmf-lite)))
+ (synopsis "Gather file system information")
+ (description
+ "The @code{sys-filesystem} library provides a cross-platform interface
+for gathering file system information, such as disk space and mount points.")
+ (home-page "https://github.com/djberg96/sys-filesystem")
+ (license license:asl2.0)))
+
(define-public mailcatcher
(package
(name "mailcatcher")