summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaider Mirza <x7and7@gmail.com>2022-06-10 20:08:19 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-11 09:19:34 +0200
commit2d7548f0cf0d4e2908bc25510d736865a4e83436 (patch)
tree6251ae722edc27c2a829d673eeaf97b1db0bb6cb
parenta99015c8783eb5281618173779a0550b15a79617 (diff)
downloadguix-patches-2d7548f0cf0d4e2908bc25510d736865a4e83436.tar
guix-patches-2d7548f0cf0d4e2908bc25510d736865a4e83436.tar.gz
gnu: Add emacs-org-auto-tangle.
* gnu/packages/emacs-xyz.scm (emacs-org-auto-tangle): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 791bb8a0ce..2f9de403af 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -113,6 +113,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
+;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18639,6 +18640,28 @@ files, allowing for actions to be performed based on search criteria.")
Chinese to English.")
(license license:gpl3+)))
+(define-public emacs-org-auto-tangle
+ (package
+ (name "emacs-org-auto-tangle")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yilkalargaw/org-auto-tangle")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zb7vcmhmjiqpbbhqrqci689rnpn10p985cs5jk9sgg66xsbrgs3"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-async))
+ (home-page "https://github.com/yilkalargaw/org-auto-tangle")
+ (synopsis "Automatically tangle code blocks on save")
+ (description
+ "@code{org-auto-tangle} allows you to automatically tangle code blocks
+whenever saving an @code{org-mode} file.")
+ (license license:bsd-2)))
+
(define-public emacs-org-auto-expand
(let ((commit "4938d5f6460e2f8f051ba9ac000b291bfa43ef62")
(revision "1"))