summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-06-11 22:54:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-11 22:55:26 +0200
commit1643402950b2d2384ec74fb69e059cc6a4c4ebed (patch)
treefd56049ce783ac1eac52cf882c85f130062f7be1
parentc23d4871a609018b16ce27f2a131f9a20bf075c2 (diff)
downloadguix-patches-1643402950b2d2384ec74fb69e059cc6a4c4ebed.tar
guix-patches-1643402950b2d2384ec74fb69e059cc6a4c4ebed.tar.gz
gnu: offlate: Update to 0.6.1.
* gnu/packages/python-xyz.scm (offlate): Update to 0.6.1.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 344a1d9089..17d77972e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24331,7 +24331,7 @@ with features similar to the @command{wget} utility.")
(define-public offlate
(package
(name "offlate")
- (version "0.5")
+ (version "0.6.1")
(source
(origin
(method git-fetch)
@@ -24341,33 +24341,37 @@ with features similar to the @command{wget} utility.")
(file-name (git-file-name name version))
(sha256
(base32
- "13pqnbl05wcyldfvl75fp89vjgwsvxyc69vhnb17kkha2rc2k1h7"))))
+ "1sx5cv8pamyw1m089b6x8ykaxdkx26jk9cblhbzlf0m3ckz52jik"))))
(build-system python-build-system)
(arguments
;; No tests
`(#:tests? #f
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-for-pygit2
- (lambda _
- (substitute* "offlate/systems/git.py"
- (("pygit2.remote.RemoteCallbacks")
- "pygit2.RemoteCallbacks")))))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'generate-fonts
+ (lambda _
+ (invoke "make" "fonts")))
+ (add-before 'build 'generate-translations
+ (lambda _
+ (invoke "make" "update-langs"))))))
(propagated-inputs
(list python-android-stringslib
python-dateutil
python-gitlab
python-lxml
python-polib
+ python-pycountry
python-pyenchant
python-pygit2
python-pygithub
python-pyqt
python-requests
python-ruamel.yaml
+ python-translate-toolkit
python-translation-finder
python-watchdog))
(native-inputs
- (list qttools))
+ (list qttools fontforge))
(home-page "https://framagit.org/tyreunom/offlate")
(synopsis "Offline translation interface for online translation tools")
(description "Offlate offers a unified interface for different translation