summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:08 +0200
commit07edc13f0431401071f29ddb1982d92f00b63327 (patch)
treec9444ea57bbb9cfe5aa5371257064a9ba92d5537
parentf0fa2b25ba9d98644af3e79f025716c46fbed29a (diff)
downloadguix-patches-07edc13f0431401071f29ddb1982d92f00b63327.tar
guix-patches-07edc13f0431401071f29ddb1982d92f00b63327.tar.gz
gnu: python-pyodbc: Document the test situation.
* gnu/packages/databases.scm (python-pyodbc)[arguments]: Replace counterfactual comment with one that isn't. Add a custom 'check phase, which doesn't run.
-rw-r--r--gnu/packages/databases.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8ae9c674fb..9bf4dc6bf0 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3058,7 +3058,15 @@ for ODBC.")
(inputs
(list unixodbc))
(arguments
- `(#:tests? #f)) ; no unit tests exist
+ ;; XXX Tests fail with ‘Can't open lib 'SQL Server Native Client 10.0' :
+ ;; file not found (0) (SQLDriverConnect)")’.
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python3" "tests3/test.py")))))))
(home-page "https://github.com/mkleehammer/pyodbc")
(synopsis "Python ODBC Library")
(description "@code{python-pyodbc} provides a Python DB-API driver