summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-06-12 09:05:20 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-12 09:07:17 +0200
commit965d54e344dcd19adf3c32f8b9d2dcab62b91e6a (patch)
treeee56908784c1588a8b6e14dcbde8c17b85fe2555
parent75eae3fd78abe3037b0e831958cfa667cc87f0b8 (diff)
downloadguix-patches-965d54e344dcd19adf3c32f8b9d2dcab62b91e6a.tar
guix-patches-965d54e344dcd19adf3c32f8b9d2dcab62b91e6a.tar.gz
gnu: java-plexus-component-metadata: Fix package.
* gnu/packages/java.scm (java-plexus-component-metadata): Apply fix for newer jdom.
-rw-r--r--gnu/packages/java.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f475f7c270..fcac0c2367 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2019, 2021 Carlo Zancanaro <carlo@zancanaro.id.au>
-;;; Copyright © 2017-2021 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2017-2022 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -4371,6 +4371,14 @@ from source tags and class annotations.")))
(copy-recursively "src/main/resources"
"build/classes/")
#t))
+ (add-before 'build 'fix-jdom
+ (lambda _
+ ;; The newer version of jdom now sets multiple features by default
+ ;; that are not supported.
+ ;; Skip these features
+ (substitute* "src/main/java/org/codehaus/plexus/metadata/merge/MXParser.java"
+ (("throw new XmlPullParserException\\(\"unsupporte feature \"\\+name\\);")
+ "// skip"))))
(add-before 'build 'reinstate-cli
;; The CLI was removed in 2.1.0, but we still need it to build some
;; maven dependencies, and some parts of maven itself. We can't use