summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:10 +0200
commit0648dc95721a6535cf5446fd2f47dc2e6f6823d9 (patch)
tree34e47682c124f32360f4adf39db4d3a6e8ecc028
parentfa924a97269c248dcdbeb526203c4290bcb0cc0c (diff)
downloadguix-patches-0648dc95721a6535cf5446fd2f47dc2e6f6823d9.tar
guix-patches-0648dc95721a6535cf5446fd2f47dc2e6f6823d9.tar.gz
gnu: rsyslog: Include rscryutil.
* gnu/packages/logging.scm (rsyslog)[arguments]: Add "--enable-usertools" and "--enable-generate-man-pages" to #:configure-flags. Move all ‘mm’ options to their own section. [native-inputs]: Add python-docutils.
-rw-r--r--gnu/packages/logging.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 86e06d9ba3..0042e4f0ef 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -252,9 +252,8 @@ library.")
;; them for a full-featured build.
'(list "--enable-kmsg"
"--enable-liblogging_stdlog"
- "--enable-mmanon"
- "--enable-mmcount"
"--enable-unlimited_select"
+ "--enable-usertools"
;; Input plugins
"--enable-imbatchreport"
@@ -296,7 +295,9 @@ library.")
"--enable-pmsnare"
;; Message Modification Modules
+ "--enable-mmanon"
"--enable-mmaudit"
+ "--enable-mmcount"
"--enable-mmdarwin"
"--enable-mmdblookup"
"--enable-mmfields"
@@ -323,9 +324,18 @@ library.")
"--enable-snmp"
;; Function modules
- "--enable-fmhash_xxhash")))
+ "--enable-fmhash_xxhash"
+
+ ;; Needed to build rscryutil.1.gz.
+ "--enable-generate-man-pages")))
(native-inputs
- (list autoconf automake bison flex libtool pkg-config))
+ (list autoconf
+ automake
+ bison
+ flex
+ libtool
+ pkg-config
+ python-docutils)) ; rst2man for man pages
(inputs
(list curl
cyrus-sasl