summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
commitfb67ebca3e397d24c57f142825dfb64d75eed8a0 (patch)
tree9ffad652d106809143b00f1caa4780bdb555d407
parent623f623209681317657396a1372728f93f70237f (diff)
downloadguix-patches-fb67ebca3e397d24c57f142825dfb64d75eed8a0.tar
guix-patches-fb67ebca3e397d24c57f142825dfb64d75eed8a0.tar.gz
gnu: reproc: Update to 14.2.4.
* gnu/packages/cpp.scm (reproc): Update to 14.2.4.
-rw-r--r--gnu/packages/cpp.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 87bd43356a..78e4f3bd8e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -886,7 +886,7 @@ and make @code{cpplint} usable in wider contexts.")
(define-public reproc
(package
(name "reproc")
- (version "14.1.0")
+ (version "14.2.4")
(source
(origin
(method git-fetch)
@@ -895,13 +895,12 @@ and make @code{cpplint} usable in wider contexts.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1n71wb50qv2dmhjgw7azx5gigbrp19l2n3d41g9p05l5l0y1qg0q"))))
+ (base32 "09xnf8hmld1fk8j33zwlz1qcxnjdx1ncbg62csic9va4m1wc2v1d"))))
(build-system cmake-build-system)
(arguments
;; No tests.
`(#:tests? #f
- ;; Enable building of shared library.
+ ;; Build the shared library instead of a static one.
#:configure-flags `("-DBUILD_SHARED_LIBS=1")))
(native-inputs
(list pkg-config))