summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
commitd080adc41683ebbc4a5d4d1dbeed1ed32a8521de (patch)
tree74ab4759052c37be95ce3a9713d126fa4e426cbe
parent211957705222ff3355f21fbb8f64458db71d32ca (diff)
downloadguix-patches-d080adc41683ebbc4a5d4d1dbeed1ed32a8521de.tar
guix-patches-d080adc41683ebbc4a5d4d1dbeed1ed32a8521de.tar.gz
gnu: multitail: Update to 6.5.2.
* gnu/packages/logging.scm (multitail): Update to 6.5.2. [arguments]: Don't explicitly return #t from phases. [source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Add SYSCONFDIR to #:make-flags. Add a new 'fix-broken-build phase. Sanitise the old 'patch-curses-lib phase to 'patch-curses-headers.
-rw-r--r--gnu/packages/logging.scm39
1 files changed, 25 insertions, 14 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 0042e4f0ef..9e7cfe613a 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -164,29 +164,40 @@ commands, displaying the results via a web interface.")
(define-public multitail
(package
(name "multitail")
- (version "6.5.0")
+ (version "6.5.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://vanheusden.com/multitail/multitail-"
- version ".tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/halturin/multitail")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1vd9vdxyxsccl64ilx542ya5vlw2bpg6gnkq1x8cfqy6vxvmx7dj"))))
+ (base32 "17hg5qpangyx4m7hp2x4h56mp6w3wsaslg1il39qcpwsffh1rihc"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
(list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "SYSCONFDIR=$(PREFIX)/etc")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-curses-lib
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "mt.h"
- (("ncursesw\\/panel.h") "panel.h")
- (("ncursesw\\/ncurses.h") "ncurses.h")))
- #t))
+ (add-after 'unpack 'fix-broken-build
+ ;; With some luck, you might be able to remove this when updating…
+ (lambda _
+ (substitute* "Makefile"
+ ((" \\*\\.txt") "")
+ ((".*CONFIG_DIR.*") "")
+ (("^install: .*" match)
+ (string-append match
+ "\t$(INSTALL_DIR) $(DESTDIR)$(SYSCONFDIR)\n")))
+ (substitute* "version"
+ (("(VERSION=).*" _ assign)
+ (string-append assign ,version)))))
+ (add-after 'unpack 'patch-curses-headers
+ (lambda _
+ (substitute* "mt.h"
+ (("ncursesw/") ""))))
(delete 'configure)) ; no configure script
#:tests? #f)) ; no test suite (make check just runs cppcheck)
(inputs (list ncurses))