summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:01 +0200
commitcb475aea08fd438935ab1cc7bc28e018ee3e080e (patch)
treec18706055ca2dcb3b5c6c670484cf574c6ce2c21
parent4cb22c07d2141b118572704d28c35290c297696b (diff)
downloadguix-patches-cb475aea08fd438935ab1cc7bc28e018ee3e080e.tar
guix-patches-cb475aea08fd438935ab1cc7bc28e018ee3e080e.tar.gz
gnu: alpine: Update to 2.26.
* gnu/packages/mail.scm (alpine): Update to 2.26. [source]: Remove patch. * gnu/packages/patches/alpine-fix-privacy-policy-crash.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/mail.scm8
-rw-r--r--gnu/packages/patches/alpine-fix-privacy-policy-crash.patch39
3 files changed, 3 insertions, 45 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index abd6a30d66..d49af0d898 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -848,7 +848,6 @@ dist_patch_DATA = \
%D%/packages/patches/akonadi-not-relocatable.patch \
%D%/packages/patches/akonadi-timestamps.patch \
%D%/packages/patches/allegro-mesa-18.2.5-and-later.patch \
- %D%/packages/patches/alpine-fix-privacy-policy-crash.patch \
%D%/packages/patches/anki-mpv-args.patch \
%D%/packages/patches/antiword-CVE-2014-8123.patch \
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c9fa62a1f3..1e2375c113 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3670,7 +3670,7 @@ operators and scripters.")
(define-public alpine
(package
(name "alpine")
- (version "2.25")
+ (version "2.26")
(source
(origin
(method git-fetch)
@@ -3683,14 +3683,12 @@ operators and scripters.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0z6dp3cpz1dmbxw41ravsx1bxychafp0ij8gvj96mzz7rm9pdnq3"))
+ (base32 "1padh9kgn9blzjf0016i2f15c615fk17m8vg8kx301jhmc2r973h"))
(modules '((guix build utils)))
(snippet
'(begin
;; Remove pre-built binaries scattered across the source repository.
- (for-each delete-file (find-files "." "\\.(dll|exe)"))))
- (patches
- (search-patches "alpine-fix-privacy-policy-crash.patch"))))
+ (for-each delete-file (find-files "." "\\.(dll|exe)"))))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
diff --git a/gnu/packages/patches/alpine-fix-privacy-policy-crash.patch b/gnu/packages/patches/alpine-fix-privacy-policy-crash.patch
deleted file mode 100644
index d514ac33a0..0000000000
--- a/gnu/packages/patches/alpine-fix-privacy-policy-crash.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-X-Git-Url: https://repo.or.cz/alpine.git/blobdiff_plain/fb2217ac67706e4cbef69bea41041e2fb8b910e9..3ee981816abfb7d47ffc0ac522fff002b5749b72:/alpine/help.c
-
-diff --git a/alpine/help.c b/alpine/help.c
-index 4f1bf46..e9c7b34 100644
---- a/alpine/help.c
-+++ b/alpine/help.c
-@@ -36,6 +36,7 @@ static char rcsid[] = "$Id: help.c 1032 2008-04-11 00:30:04Z hubert@u.washington
- #include "../pith/detoken.h"
- #include "../pith/list.h"
- #include "../pith/margin.h"
-+#include "../pith/busy.h"
-
-
- typedef struct _help_scroll {
-@@ -135,10 +136,12 @@ helper_internal(HelpType text, char *frag, char *title, int flags)
- is_external = 0;
-
- if(shown_text && *shown_text && !struncmp(*shown_text, "x-alpine-http:", 14)){
-- int status;
-+ int status, we_cancel = 0;
-+
-+ we_cancel = busy_cue(_("Retrieving help text"), NULL, 1);
- HTTPSTREAM *stream = http_open(*shown_text + 14);
- if(stream) help_text = http_get(stream, NULL);
-- status = stream->status ? stream->status->code : -1;
-+ status = stream && stream->status ? stream->status->code : -1;
- if(stream) http_close(stream);
- if(status != HTTP_OK){
- shown_text = NO_HELP;
-@@ -165,7 +168,8 @@ helper_internal(HelpType text, char *frag, char *title, int flags)
- *rv = NULL;
- }
- }
--
-+ if(we_cancel)
-+ cancel_busy_cue(-1);
- }
-
- if(F_ON(F_BLANK_KEYMENU,ps_global)){