summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-06-05 22:14:15 -0500
committerLudovic Courtès <ludo@gnu.org>2022-06-10 23:04:14 +0200
commitc09cc71724dfa6b6528445ea44b6aa6149bd9fa3 (patch)
treed7d521277bac554e450603c6def5faa9e84e1c3b
parent8d4a69eb90d38b74bac667476c7968d1d5ed9fad (diff)
downloadguix-patches-c09cc71724dfa6b6528445ea44b6aa6149bd9fa3.tar
guix-patches-c09cc71724dfa6b6528445ea44b6aa6149bd9fa3.tar.gz
gnu: direnv: Update to 2.31.0.
* gnu/packages/shellutils.scm (direnv): Update to 2.31.0. [arguments]: Remove trailing boolean in lambda block. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/shellutils.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index d0f4068062..ad674a3989 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -368,7 +368,7 @@ are already there.")
(define-public direnv
(package
(name "direnv")
- (version "2.28.0")
+ (version "2.31.0")
(source
(origin (method git-fetch)
(uri (git-reference
@@ -377,7 +377,7 @@ are already there.")
(file-name (git-file-name name version))
(sha256
(base32
- "0yk53jn7wafklixclka17wyjjs2g5giigjr2bd0xzy10nrzwp7c9"))))
+ "1c52izjzkdhmyrfx1gmbp34n0qpxyxw0s94f0vy3ldlg8xr36wmk"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/direnv/direnv"
@@ -405,8 +405,7 @@ are already there.")
(invoke "go" "test" "./...")
;; Clean up from the tests, especially so that the extra
;; direnv executable that's generated is removed.
- (invoke "make" "clean")))
- #t)))))
+ (invoke "make" "clean"))))))))
(native-inputs
(list go-github-com-burntsushi-toml go-github-com-direnv-go-dotenv
go-github-com-mattn-go-isatty go-golang-org-x-mod which))