summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-06-08 20:05:30 -0400
committerChristopher Baines <mail@cbaines.net>2022-06-10 11:21:55 +0100
commit9ea5a66e30f709816e477dedfcfcfb1d8563917a (patch)
tree37eee95085080096ca7775f19d27e1a055ed70d0
parent0f04db3262cffeafce2861fde5ac30327b5222ab (diff)
downloadguix-patches-9ea5a66e30f709816e477dedfcfcfb1d8563917a.tar
guix-patches-9ea5a66e30f709816e477dedfcfcfb1d8563917a.tar.gz
gnu: Add emacs-platformio-mode.
* gnu/packages/emacs-xyz.scm (emacs-platformio-mode): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 792c261851..8388dfeae5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -568,6 +568,27 @@ editing @file{.hgignore} files used by the Mercurial version control
system.")
(license license:gpl3+))))
+(define-public emacs-platformio-mode
+ (package
+ (name "emacs-platformio-mode")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ZachMassia/PlatformIO-Mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ian50v9vaz7kqzn20bhqadq50h0l3zhjkmniinpz4q9klh7drh9"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-async emacs-projectile))
+ (home-page "https://github.com/zachmassia/platformio-mode")
+ (synopsis "Minor mode for building and uploading PlatformIO projects")
+ (description "This package provices an Emacs minor mode for building and
+uploading PlatformIO projects.")
+ (license license:gpl3+)))
+
(define-public emacs-hyperbole
(package
(name "emacs-hyperbole")