summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-06-09 10:35:07 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-06-10 11:07:04 +0200
commit9d2ef7344e340747640dc00413aa6a7b054f022a (patch)
tree3633d3656e395557df5d2e995155729ad1ae9a40
parentd998f5ad86db748b85b4a2262da864e6ae4dfc7f (diff)
downloadguix-patches-9d2ef7344e340747640dc00413aa6a7b054f022a.tar
guix-patches-9d2ef7344e340747640dc00413aa6a7b054f022a.tar.gz
gnu: python-pydevd: Skip tests failing due to YAMA.
* gnu/packages/python-xyz.scm (python-pydevd)[arguments]: Add skipped tests.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6b412e799..d93877e9a3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12357,7 +12357,11 @@ libmagic.")))
;; This test validates that 'pydevd' is not in the
;; exception message, but it is due to being part
;; of the build file name present in the message.
- "and not test_evaluate_exception_trace")))))
+ "and not test_evaluate_exception_trace "
+ ;; These fail on systems with YAMA LSM’s ptrace
+ ;; scope > 0. Upstream issue:
+ ;; https://github.com/fabioz/PyDev.Debugger/issues/218
+ "and not test_attach_to_pid")))))
(add-after 'install 'install-attach-binary
(lambda _
(install-file "attach.so"