summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-06-09 10:35:33 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-06-10 11:07:04 +0200
commit3e6bc1edca0c7ee4e8bfe0d8e783db48d2bb647c (patch)
treedae9d2a8acd098a288a124f2274ca305dc172643
parent9d2ef7344e340747640dc00413aa6a7b054f022a (diff)
downloadguix-patches-3e6bc1edca0c7ee4e8bfe0d8e783db48d2bb647c.tar
guix-patches-3e6bc1edca0c7ee4e8bfe0d8e783db48d2bb647c.tar.gz
gnu: python-debugpy: Disable tests.
* gnu/packages/python-xyz.scm (python-debugpy)[arguments]: Respect tests? in 'check phase and disable #:tests.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d93877e9a3..92adf74393 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12406,6 +12406,7 @@ and other @acronym{IDEs, Integrated Development Environments}.")
(build-system python-build-system)
(arguments
(list
+ #:tests? #f ; Fail on systems with YAMA LSM’s ptrace scope > 0.
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-sh-in-tests
@@ -12426,17 +12427,18 @@ and other @acronym{IDEs, Integrated Development Environments}.")
(setenv "DEBUGPY_BUNDLING_DISABLED" "1")))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
- (invoke "pytest" "-vv"
- "-n" (number->string (parallel-job-count))
- "-k"
- (string-append
- ;; These tests cannot be run in parallel because their
- ;; test data would not be copied by xdist and lead to
- ;; import errors. (see:
- ;; https://github.com/microsoft/debugpy/issues/342 and
- ;; https://github.com/microsoft/debugpy/issues/880).
- "not test_custom_python_args "
- "and not test_autokill ")))))))
+ (when tests?
+ (invoke "pytest" "-vv"
+ "-n" (number->string (parallel-job-count))
+ "-k"
+ (string-append
+ ;; These tests cannot be run in parallel because their
+ ;; test data would not be copied by xdist and lead to
+ ;; import errors. (see:
+ ;; https://github.com/microsoft/debugpy/issues/342 and
+ ;; https://github.com/microsoft/debugpy/issues/880).
+ "not test_custom_python_args "
+ "and not test_autokill "))))))))
(native-inputs
;; See: https://raw.githubusercontent.com/microsoft/debugpy/
;; main/tests/requirements.txt.