summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-10-11 00:01:41 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-10-16 02:50:21 +0530
commit30ddb0be6514e3d48609b10b9581e6dd32d9cd40 (patch)
tree38bd604a4386bbb65e5600789a251c9d9a3dc480
parent058ea2672b8e2e3bb3097651727bf7e7e1aee1f5 (diff)
downloadguix-patches-30ddb0be6514e3d48609b10b9581e6dd32d9cd40.tar
guix-patches-30ddb0be6514e3d48609b10b9581e6dd32d9cd40.tar.gz
gnu: emacs-org-roam: Reference dot with absolute path.
* gnu/packages/emacs-xyz.scm (emacs-org-roam)[inputs]: Add graphviz. [arguments]: Add patch-exec-paths phase substituting absolute store path to dot.
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 77c77769fb..b3178d9649 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -153,6 +153,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages haskell-apps)
#:use-module (gnu packages ibus)
#:use-module (gnu packages java)
@@ -28387,6 +28388,13 @@ snippets for Emacs.")
(rename-file f (basename f)))
el-files))
#t))
+ (add-after 'move-source-files 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "org-roam-graph.el")
+ (emacs-substitute-variables "org-roam-graph.el"
+ ("org-roam-graph-executable"
+ (string-append (assoc-ref inputs "graphviz")
+ "/bin/dot")))))
(add-after 'install 'install-image
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -28399,6 +28407,8 @@ snippets for Emacs.")
(invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
(install-file "org-roam.info"
(string-append out "/share/info")))))))))
+ (inputs
+ `(("graphviz" ,graphviz)))
(native-inputs
`(("texinfo" ,texinfo)))
(propagated-inputs