summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-06-10 15:53:36 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-06-10 16:56:57 -0700
commit2f3dec3de76011b2bd7b19e50a1b12b8d6697a34 (patch)
treea9f826eca2aa0f508c0994f6ca3bfd5f3b90c547
parent010426e2c34428d69573cdfef88239303edcab2d (diff)
downloadguix-patches-2f3dec3de76011b2bd7b19e50a1b12b8d6697a34.tar
guix-patches-2f3dec3de76011b2bd7b19e50a1b12b8d6697a34.tar.gz
gnu: tch-ipv6: Build reproducibly.
* gnu/packages/networking.scm (thc-ipv6)[arguments]: Add 'use-source-date-epoch-in-manpages phase.
-rw-r--r--gnu/packages/networking.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cd25ca3dce..bfb4e32296 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2772,6 +2772,12 @@ updates to the zebra daemon.")
#:tests? #f ; No test suite.
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'use-source-date-epoch-in-manpages
+ ;; For reproducible builds
+ (lambda _
+ (substitute* "Makefile"
+ (("date --iso-8601")
+ "date --iso-8601 --utc --date=@$(SOURCE_DATE_EPOCH)"))))
(delete 'configure) ; No ./configure script.
(add-before 'build 'patch-paths
(lambda _