summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-08 17:09:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-08 17:11:23 -0400
commit8ef651b44cd8803c5e22edcbe423eae365585e48 (patch)
tree241347e75a27d6296c8f23e62077b1139b204e50
parent3f922e229bcef03e5b0c5b1325d031c27371bcac (diff)
downloadguix-patches-8ef651b44cd8803c5e22edcbe423eae365585e48.tar
guix-patches-8ef651b44cd8803c5e22edcbe423eae365585e48.tar.gz
gnu: ngspice: Build with readline support.
Fixes <https://issues.guix.gnu.org/>. * gnu/packages/engineering.scm (ngspice) [configure-flags]: Add '--with-readline=yes'. Reported-by: Christopher Howard <christopher@librehacker.com>
-rw-r--r--gnu/packages/engineering.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6b11fc54f0..a3a2ffe5e4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1840,7 +1840,8 @@ an embedded event driven algorithm.")
(arguments
(substitute-keyword-arguments (package-arguments libngspice)
((#:configure-flags flags)
- `(delete "--with-ngshared" ,flags))
+ `(cons "--with-readline=yes"
+ (delete "--with-ngshared" ,flags)))
((#:phases phases)
`(modify-phases ,phases
(add-after 'unpack 'delete-include-files