summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-08 20:57:18 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-08 21:26:30 +0200
commit3f922e229bcef03e5b0c5b1325d031c27371bcac (patch)
treefb70e6b92c408a9cbdf8d15ef0bdfe89f2a9be5f
parent731f55aa8df4e5a7715681cfe168188b2e57feb6 (diff)
downloadguix-patches-3f922e229bcef03e5b0c5b1325d031c27371bcac.tar
guix-patches-3f922e229bcef03e5b0c5b1325d031c27371bcac.tar.gz
gnu: epiphany: Use new coding style.
* gnu/packages/gnome.scm (epiphany)[arguments]: Convert to list of G-Expressions. [propagated-inputs]: Reindent. [inputs, native-inputs]: Drop labels and reindent.
-rw-r--r--gnu/packages/gnome.scm106
1 files changed, 52 insertions, 54 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5c23d8b42e..e6573894b4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6714,60 +6714,58 @@ a secret password store, an adblocker, and a modern UI.")
"0b8rhns3b58f8dnp83mm1g933aqf88d8wrfyyp7jq3fihvw2rh4j"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "post_install.py"
- (("gtk-update-icon-cache") "true"))))
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "tests/meson.build"
- ;; embed_shell fails, because webkitgtk apparently no longer
- ;; supports overriding the ftp schema web_app_utils fails due
- ;; to missing network access.
- (("(embed_shell|web_app_utils)_test,")
- "find_program('sh'), args: ['-c', 'exit 77'],"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))
- #:configure-flags
- ;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
- (list (string-append "-Dc_link_args=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib/epiphany"))))
- (propagated-inputs
- (list dconf))
- (native-inputs
- `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
- ("glib:bin" ,glib "bin") ; for glib-mkenums
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("pkg-config" ,pkg-config)
- ("xmllint" ,libxml2)
- ("xorg-server" ,xorg-server-for-tests)))
- (inputs
- `(("avahi" ,avahi)
- ("gcr" ,gcr)
- ("librsvg" ,librsvg) ; for loading SVG files
- ("glib-networking" ,glib-networking)
- ("gnome-desktop" ,gnome-desktop)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("json-glib" ,json-glib)
- ("iso-codes" ,iso-codes)
- ("libarchive" ,libarchive)
- ("libdazzle" ,libdazzle)
- ("libhandy" ,libhandy)
- ("libnotify" ,libnotify)
- ("libportal" ,libportal)
- ("libsecret" ,libsecret)
- ("libxslt" ,libxslt)
- ("nettle" ,nettle) ; for hogweed
- ("sqlite" ,sqlite)
- ("webkitgtk" ,webkitgtk-with-libsoup2)))
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "post_install.py"
+ (("gtk-update-icon-cache") "true"))))
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ ;; embed_shell fails, because webkitgtk apparently no longer
+ ;; supports overriding the ftp schema web_app_utils fails due
+ ;; to missing network access.
+ (("(embed_shell|web_app_utils)_test,")
+ "find_program('sh'), args: ['-c', 'exit 77'],"))))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))
+ #:configure-flags
+ ;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
+ #~(list (string-append "-Dc_link_args=-Wl,-rpath="
+ #$output "/lib/epiphany"))))
+ (propagated-inputs (list dconf))
+ (native-inputs (list desktop-file-utils ; for update-desktop-database
+ `(,glib "bin") ; for glib-mkenums
+ intltool
+ itstool
+ pkg-config
+ libxml2
+ xorg-server-for-tests))
+ (inputs (list avahi
+ gcr
+ librsvg ; for loading SVG files
+ glib-networking
+ gnome-desktop
+ gsettings-desktop-schemas
+ json-glib
+ iso-codes
+ libarchive
+ libdazzle
+ libhandy
+ libnotify
+ libportal
+ libsecret
+ libxslt
+ nettle ; for hogweed
+ sqlite
+ webkitgtk-with-libsoup2))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description