summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 12:33:12 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 09:36:04 +0800
commitd1ae5a12150a8d83c33de4dae1401b3aaffeacbc (patch)
tree7353fb22c4370d86a2558ccb48e67db2b84d3fff
parent5914489dabee362bdcce1f377ec588b937035f99 (diff)
downloadguix-patches-d1ae5a12150a8d83c33de4dae1401b3aaffeacbc.tar
guix-patches-d1ae5a12150a8d83c33de4dae1401b3aaffeacbc.tar.gz
gnu: Add cl+ssl.
* gnu/packages/lisp.scm (sbcl-cl+ssl, cl-cl+ssl): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a24988d3e0..1025cc7f72 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xorg)
#:use-module (gnu packages databases)
@@ -3840,3 +3841,45 @@ client and server.")
(define-public ecl-trivial-clipboard
(sbcl-package->ecl-package sbcl-trivial-clipboard))
+
+(define-public sbcl-cl+ssl
+ (let ((commit "b81c1135cf5700e870ce2573d5035d249e491788")
+ (revision "1"))
+ (package
+ (name "sbcl-cl+ssl")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cl-plus-ssl/cl-plus-ssl.git")
+ (commit commit)))
+ (sha256
+ (base32 "1845i1pafmqb6cdlr53yaqy67kjrhkvbx6c37ca15cw70vhdr3z9"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/reload.lisp"
+ (("libssl.so" all)
+ (string-append
+ (assoc-ref inputs "openssl") "/lib/" all))))))))
+ (inputs
+ `(("openssl" ,openssl)
+ ("sbcl-cffi" ,sbcl-cffi)
+ ("sbcl-trivial-gray-streams" ,sbcl-trivial-gray-streams)
+ ("sbcl-flexi-streams" ,sbcl-flexi-streams)
+ ("sbcl-bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("sbcl-trivial-garbage" ,sbcl-trivial-garbage)))
+ (home-page "http://common-lisp.net/project/cl-plus-ssl/")
+ (synopsis "Common Lisp bindings to OpenSSL")
+ (description
+ "This library is a fork of SSL-CMUCL. The original SSL-CMUCL source
+code was written by Eric Marsden and includes contributions by Jochen Schmidt.
+Development into CL+SSL was done by David Lichteblau.")
+ (license license:expat))))
+
+(define-public cl-cl+ssl
+ (sbcl-package->cl-source-package sbcl-cl+ssl))