summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-08 20:51:04 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-06-08 21:25:20 +0200
commit731f55aa8df4e5a7715681cfe168188b2e57feb6 (patch)
tree172495a5e172f815bb6ca0ffb5995db69daee804
parent48a191c15d52073185d4ca7e81c63517d779df27 (diff)
downloadguix-patches-731f55aa8df4e5a7715681cfe168188b2e57feb6.tar
guix-patches-731f55aa8df4e5a7715681cfe168188b2e57feb6.tar.gz
gnu: epiphany: Update to 42.2.
* gnu/packages/gnome.scm (epiphany): Update to 42.2. [source]: Remove patches. * gnu/packages/patches/epiphany-update-libportal-usage.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--gnu/packages/patches/epiphany-update-libportal-usage.patch53
3 files changed, 2 insertions, 58 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 453d3bb9a9..abd6a30d66 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1039,7 +1039,6 @@ dist_patch_DATA = \
%D%/packages/patches/enjarify-setup-py.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
%D%/packages/patches/eog-update-libportal-usage.patch \
- %D%/packages/patches/epiphany-update-libportal-usage.patch \
%D%/packages/patches/erlang-man-path.patch \
%D%/packages/patches/esmtp-add-lesmtp.patch \
%D%/packages/patches/eudev-rules-directory.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 90ee724290..5c23d8b42e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6703,7 +6703,7 @@ a secret password store, an adblocker, and a modern UI.")
(define-public epiphany
(package
(name "epiphany")
- (version "41.2")
+ (version "42.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -6711,9 +6711,7 @@ a secret password store, an adblocker, and a modern UI.")
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "0k7b22zq3z1kllzqxgwsvwb1lp0j6rjb3k1hvhna3i573wc4mpji"))
- (patches
- (search-patches "epiphany-update-libportal-usage.patch"))))
+ "0b8rhns3b58f8dnp83mm1g933aqf88d8wrfyyp7jq3fihvw2rh4j"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
diff --git a/gnu/packages/patches/epiphany-update-libportal-usage.patch b/gnu/packages/patches/epiphany-update-libportal-usage.patch
deleted file mode 100644
index 0d8ea045fb..0000000000
--- a/gnu/packages/patches/epiphany-update-libportal-usage.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Fix for epiphany with libportal-0.5.
-
-This patch was adapted from upstream
-https://gitlab.gnome.org/GNOME/epiphany/-/commit/e4d259f614f75c26ad0d2094f4f569ffd1bc06d1
-
-diff --git a/lib/ephy-flatpak-utils.c b/lib/ephy-flatpak-utils.c
-index 6fc9a5dec17a63c0660cbc1d95103c8f77231d30..0fd90b3f178392930e812a8391fd81bf1371b8bf 100644
---- a/lib/ephy-flatpak-utils.c
-+++ b/lib/ephy-flatpak-utils.c
-@@ -29,7 +29,7 @@
- #include <gio/gio.h>
- #include <gio/gunixfdlist.h>
- #if USE_LIBPORTAL
--#include <libportal/portal-gtk3.h>
-+#include <libportal-gtk3/portal-gtk3.h>
- #endif
- #include <string.h>
- #include <sys/stat.h>
-diff --git a/lib/meson.build b/lib/meson.build
-index 264f9c5fb66268fc248f780b8d1c06c8291f856d..db0a0557f0ae634d7fb95e57aba0cd901ca4d6c1 100644
---- a/lib/meson.build
-+++ b/lib/meson.build
-@@ -66,6 +66,7 @@ libephymisc_deps = [
- libxml_dep,
- m_dep,
- portal_dep,
-+ portal_gtk_dep,
- sqlite3_dep,
- webkit2gtk_dep
- ]
-diff --git a/meson.build b/meson.build
-index 0b9f862b22a23619289342ec39fa0a0274558c25..4285a975004e48366789a4e66f8b23f3af05a636 100644
---- a/meson.build
-+++ b/meson.build
-@@ -95,7 +95,8 @@ libhandy_dep = dependency('libhandy-1', version: '>= 1.5.0')
- libsecret_dep = dependency('libsecret-1', version: '>= 0.19.0')
- libxml_dep = dependency('libxml-2.0', version: '>= 2.6.12')
- nettle_dep = dependency('nettle', version: nettle_requirement)
--portal_dep = dependency('libportal', version: '>= 0.0.2', required: get_option('libportal'))
-+portal_dep = dependency('libportal', version: '>= 0.5', required: get_option('libportal'))
-+portal_gtk_dep = dependency('libportal-gtk3', version: '>= 0.5', required: get_option('libportal'))
- sqlite3_dep = dependency('sqlite3', version: '>= 3.22')
-
- if get_option('soup2').enabled()
-@@ -108,7 +109,7 @@ else
- webkit2gtk_web_extension_dep = dependency('webkit2gtk-web-extension-4.1', version: webkitgtk_requirement)
- endif
-
--conf.set10('USE_LIBPORTAL', portal_dep.found())
-+conf.set10('USE_LIBPORTAL', portal_dep.found() and portal_gtk_dep.found())
-
- webkit_revision = webkit2gtk_dep.get_variable(pkgconfig : 'revision', default_value : '')
- if webkit_revision == 'tarball'