summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-06 22:18:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-06 22:18:36 +0300
commitb995c1bd10e445cfdabadb1a5e30935729ce094c (patch)
treed53b0cf77e620c2e7e051324f9aac51cba280276
parentb9c8c3585bab79a44d820a43f9bf4597445e7929 (diff)
downloadguix-patches-b995c1bd10e445cfdabadb1a5e30935729ce094c.tar
guix-patches-b995c1bd10e445cfdabadb1a5e30935729ce094c.tar.gz
gnu: python-flake8: Allow building with newer python-pyflakes.
* gnu/packages/python-xyz.scm (python-flake8)[source]: Add snippet to remove upper bound on dependency python-pyflakes version.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index feb211edb8..6132019a53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10200,7 +10200,14 @@ cyclomatic complexity of Python source code.")
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "0sspgh2ph7bb5fmf49mrdhi7n5m421kfkxk1n0vn4akgg20q6lh7"))))
+ "0sspgh2ph7bb5fmf49mrdhi7n5m421kfkxk1n0vn4akgg20q6lh7"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (substitute* "setup.cfg"
+ ;; Remove upper bound on pyflakes version.
+ (("(pyflakes >=.*), .*" _ pyflakes)
+ (string-append pyflakes "\n")))))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases