summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:11 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:51 -0500
commit9f21414de4475a80722c827771af55ce7175fb19 (patch)
tree4e1b11c612267ac324d4915d6f869902d401ec11
parenta2c7d88e74b89b7370fc633fca76f9ba8095a6fc (diff)
downloadguix-patches-9f21414de4475a80722c827771af55ce7175fb19.tar
guix-patches-9f21414de4475a80722c827771af55ce7175fb19.tar.gz
gnu: Add python-kitchen.
* gnu/packages/python.scm (python-kitchen, python2-kitchen): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b5a84d824a..ea06d95dcd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2538,6 +2538,34 @@ version numbers.")
(propagated-inputs
`(("python2-functools32" ,python2-functools32))))))
+(define-public python-kitchen
+ (package
+ (name "python-kitchen")
+ (version "1.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "kitchen" version))
+ (sha256
+ (base32
+ "0ggv3p4x8jvmmzhp0xm00h6pvh1g0gmycw71rjwagnrj8n23vxrq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-chardet" ,python-chardet)))
+ (home-page "https://fedorahosted.org/kitchen")
+ (synopsis "Python API for snippets")
+ (description "@code{kitchen} module provides a python API for all sorts of
+little useful snippets of code that everybody ends up writing for their projects
+but never seem big enough to build an independent release. Use kitchen and stop
+cutting and pasting that code over and over.")
+ (license (list license:lgpl2.1+
+ ;; subprocess.py, test_subprocess.py,
+ ;; kitchen/pycompat25/defaultdict.py:
+ license:psfl))))
+
+(define-public python2-kitchen
+ (package-with-python2 python-kitchen))
+
(define-public python-unidecode
(package
(name "python-unidecode")