summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2022-05-29 13:40:28 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-06-07 21:01:41 +0200
commit5f4946fac56cff6762edd7d5a0c357ec8bb27e51 (patch)
treed9a4d468d5dcf21880476f7b918dbdeed225fe28
parentb42ed3b77c4ff3234f62d6450687991b9772b7e7 (diff)
downloadguix-patches-5f4946fac56cff6762edd7d5a0c357ec8bb27e51.tar
guix-patches-5f4946fac56cff6762edd7d5a0c357ec8bb27e51.tar.gz
gnu: Add emacs-popon.
* gnu/packages/emacs-xyz.scm (emacs-popon): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3d49b154b9..5222d48c24 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31407,6 +31407,33 @@ zoomable and moveable map display, display of tracks and POIs from GPX files,
parallel fetching of tiles with cURL, and more.")
(license license:gpl3+)))
+(define-public emacs-popon
+ ;; Upstream does not tag releases. The commit below matches the version
+ ;; bump.
+ (let ((commit "d16cb747d356eab3f1bc4061ecee473732f7b8bb"))
+ (package
+ (name "emacs-popon")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://codeberg.org/akib/emacs-popon")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i5rp0gvcdqakzaznsh0lqzvlq5kif9q2grq4l80gl75dmqdpym7"))))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/akib/emacs-popon/")
+ (synopsis "Pop floating text on a window")
+ (description
+ "@code{emacs-popon} allows you to pop text on a window, what we call
+a popon. Popons are window-local and sticky, they don't move while
+scrolling, and they even don't go away when switching buffer, but you
+can bind a popon to a specific buffer to only show on that buffer.")
+ (license license:gpl3+))))
+
(define-public emacs-bitbake-modes
(package
(name "emacs-bitbake-modes")