summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-21 11:47:14 +0000
committerLeo Famulari <leo@famulari.name>2016-12-28 22:41:52 -0500
commit3ef00f56090ad20e55eeab09ae82803211b07024 (patch)
tree26529cc4c67f7b748fe8f55647bcb2058a6c93a8
parent0151a8df22e578e06b7a4ed633a018c58330f625 (diff)
downloadguix-patches-3ef00f56090ad20e55eeab09ae82803211b07024.tar
guix-patches-3ef00f56090ad20e55eeab09ae82803211b07024.tar.gz
gnu: Add python2-openid.
* gnu/packages/python.scm (python2-openid): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c69a49f0b2..36e3df8735 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5138,6 +5138,27 @@ features useful for text console applications.")
(define-public python2-urwid
(package-with-python2 python-urwid))
+(define-public python2-openid
+ (package
+ (name "python2-openid")
+ (version "2.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-openid" version))
+ (sha256
+ (base32
+ "1vvhxlghjan01snfdc4k7ykd80vkyjgizwgg9bncnin8rqz1ricj"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Python 3 support is in `python3-openid`, a separate package.
+ `(#:python ,python-2))
+ (home-page "https://github.com/openid/python-openid")
+ (synopsis "OpenID support for servers and consumers")
+ (description "This library provides OpenID authentication for Python, both
+for clients and servers.")
+ (license license:asl2.0)))
+
(define-public python-urwidtrees
(package
(name "python-urwidtrees")