summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-05-27 14:37:22 -0400
committerLudovic Courtès <ludo@gnu.org>2022-06-06 22:43:30 +0200
commit2aceb1e13ee994385bd20cfc8a59346366447199 (patch)
treecead93d90c85c522c321ad3886af977888335e17
parent618f665a5ffc6330bc99c4ac2b1077c1e1a7506c (diff)
downloadguix-patches-2aceb1e13ee994385bd20cfc8a59346366447199.tar
guix-patches-2aceb1e13ee994385bd20cfc8a59346366447199.tar.gz
gnu: Add python-canopen.
* gnu/packages/python-xyz.scm (python-canopen): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6132019a53..17e9a922fb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2072,6 +2072,30 @@ abstractions to different hardware devices, and a suite of utilities for
sending and receiving messages on a CAN bus.")
(license license:lgpl3+)))
+(define-public python-canopen
+ (package
+ (name "python-canopen")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "canopen" version))
+ (sha256
+ (base32 "1nb543wb37kj95v6bhh272lm5gkpi41q3pnsl1fxlyizm2gamj5w"))))
+ (build-system python-build-system)
+ (native-inputs (list python-packaging))
+ (propagated-inputs (list python-can))
+ (home-page "https://github.com/christiansandberg/canopen")
+ (synopsis "CANopen stack implementation")
+ (description
+ "This package provides a Python implementation of the
+@uref{https://www.can-cia.org/canopen/,CANopen standard} for
+@acronym{CANs, controller-area networks}. The aim of the project is to
+support the most common parts of the CiA 301 standard in a simple
+Pythonic interface. It is mainly targeted for testing and automation
+tasks rather than a standard compliant master implementation.")
+ (license license:expat)))
+
(define-public python-caniusepython3
(package
(name "python-caniusepython3")