summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-06 17:17:38 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-07 09:11:54 -0400
commitda0839c77dedc6f6fcbbe503fda8a58a27af2e51 (patch)
treece82a33f01b628f90e00ee2b687bf8077feb243e
parent036a4642580831ea7784f8dcd1d1d5d314a52223 (diff)
downloadguix-patches-da0839c77dedc6f6fcbbe503fda8a58a27af2e51.tar
guix-patches-da0839c77dedc6f6fcbbe503fda8a58a27af2e51.tar.gz
gnu: trezor-agent: Update to 0.14.4.
* gnu/packages/finance.scm (trezor-agent): Update to 0.14.4. [phases]{relax-requirements}: New phase.
-rw-r--r--gnu/packages/finance.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f342b537e0..ecd20969fe 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1110,7 +1110,7 @@ the KeepKey Hardware Wallet.")
(define-public trezor-agent
(package
(name "trezor-agent")
- (version "0.11.0-1")
+ (version "0.14.4")
(source
(origin
(method git-fetch)
@@ -1150,6 +1150,11 @@ the KeepKey Hardware Wallet.")
;; This package only has a Python script, not a Python module, so the
;; sanity-check phase can't work.
(delete 'sanity-check)
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("'trezor\\[hidapi]>=0.12.0,<0.13'")
+ "'trezor[hidapi]>=0.13'"))))
(add-after 'wrap 'fixup-agent-py
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))