summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2022-06-02 13:59:11 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-07 18:29:13 +0200
commitd78478758e11fa67fed29d6b61d6e30843216219 (patch)
tree36a0ad8f86c0cf4af0c44b84555c6e69fc7ec612
parent2c8c9403ae4f9a38d2754d3363797bf216e363fb (diff)
downloadguix-patches-d78478758e11fa67fed29d6b61d6e30843216219.tar
guix-patches-d78478758e11fa67fed29d6b61d6e30843216219.tar.gz
gnu: Add edlin.
* gnu/packages/text-editors.scm (edlin): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/text-editors.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index cb86a907ff..1c936be6a8 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
+;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1132,6 +1133,38 @@ systems that displays its buffer(s) as a hex dump. The user interface is kept
similar to vi/ex.")
(license license:bsd-3)))
+(define-public edlin
+ (package
+ (name "edlin")
+ (version "2.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/freedos-edlin/freedos-edlin/"
+ version "/edlin-" version ".tar.bz2"))
+ (sha256
+ (base32 "0cdv42ffminncwj5ph9lw0j7zpbv8l35acppy90wj7x1qm4qk6x8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-read-only
+ (lambda _
+ ;; Remove executable bits.
+ (chmod "COPYING" #o444)
+ (chmod "edlin.htm" #o444)))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((doc-dir (string-append (assoc-ref outputs "out")
+ "/share/doc/edlin-" ,version)))
+ (mkdir-p doc-dir)
+ (install-file "edlin.htm" doc-dir)))))))
+ (home-page "https://sourceforge.net/projects/freedos-edlin/")
+ (synopsis "The line editor of the FreeDOS operating system")
+ (description "The @code{edlin} program is a small line editor, written for
+FreeDOS as a functional clone of the old MS-DOS program edlin.")
+ (license license:gpl2+)))
+
(define-public tree-sitter
(package
(name "tree-sitter")