summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-06 22:33:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-07 09:11:56 -0400
commitceeb2bfcaeb4380e01d26c8425e28b94ac13558a (patch)
tree48d8261bdc839eed9367f6101ece5859d950e8a3
parente3d2650726e0345b52649558d9319da3e6a8898a (diff)
downloadguix-patches-ceeb2bfcaeb4380e01d26c8425e28b94ac13558a.tar
guix-patches-ceeb2bfcaeb4380e01d26c8425e28b94ac13558a.tar.gz
gnu: offlate: Fix build.
* gnu/packages/python-xyz.scm (offlate) [phases]{patch-for-pygit2}: New phase.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f58510ae8c..2c76ff1922 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24334,7 +24334,13 @@ with features similar to the @command{wget} utility.")
(build-system python-build-system)
(arguments
;; No tests
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-for-pygit2
+ (lambda _
+ (substitute* "offlate/systems/git.py"
+ (("pygit2.remote.RemoteCallbacks")
+ "pygit2.RemoteCallbacks")))))))
(propagated-inputs
(list python-android-stringslib
python-dateutil