summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-06 16:11:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-07 09:11:53 -0400
commit8df6117b781d426a565dde64208b9a20987a4762 (patch)
tree0442297931d9d0275b397309aac3c60202c52da6
parent53a0e405ff37ac24dd9baf6114ca71cae4268fee (diff)
downloadguix-patches-8df6117b781d426a565dde64208b9a20987a4762.tar
guix-patches-8df6117b781d426a565dde64208b9a20987a4762.tar.gz
gnu: python-flask-restx: Skip networking dependent test.
* gnu/packages/python-web.scm (python-flask-restx) [phases]{check}: Skip the 'test_redirect' test.
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 80ed6a27b1..06a0d2593b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5869,8 +5869,10 @@ based on filters.")
(lambda _
(invoke "pytest" "--benchmark-skip" "-k"
;; Those tests need internet access
- "not test_check and not test_valid_value_check \
-and not test_override_app_level"))))))
+ (string-join
+ '("not test_check and not test_valid_value_check \
+and not test_override_app_level"
+ "not test_redirect") " and ")))))))
(home-page "https://github.com/python-restx/flask-restx")
(synopsis
"Framework for fast, easy and documented API development with Flask")